Announcement

Collapse
No announcement yet.

Trim will not work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trim will not work

    The trim and tilt on my 1992 Merc 200 will not go up or down. The motor works in both directions but will not raise or lower the engine. I've checked and added fluid to reservoir and someone told me to hit the up button while adding fluid but its still a no.

    I did leave the engine partially up and it did not bleed down over night so apparently it holds some pressure

    Any ideas?
    20 Seacraft MA undergoing some work[br]

  • #2
    Have you had trim motor off? Did you put coupler back in place?

    If something has failed internally I would not spend long messing with it- trim units are 250-300 on ebay. Bolt on part.

    Comment


    • #3
      I have not had the trim motor off

      What and where is the coupler located at?
      20 Seacraft MA undergoing some work[br]

      Comment


      • #4
        So with nothing to lose except a trip to the mechanic I took off the trim motor and found the piece that connects the motor to the rest. It's a small part and easy to miss. It took me 4 or 5 times to get back on correctly but it worked. One of the switches was intermittent so I bought a new one.

        What I found funny is that the coupler has no real part to hold it in place. Looked up a diagram of the trim motor and found that there was none also. Well will now it goes.

        Just about time to water test it
        20 Seacraft MA undergoing some work[br]

        Comment

        Working...
        X