Announcement

Collapse
No announcement yet.

Bennett Trim Tab Motor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bennett Trim Tab Motor

    I have gone over the troubleshooting tips from Bennett and the ones that Warthog had posted from tabman, so i'm pretty sure i ruled out anything electrical. Here is the problem, i have power getting to the unit but all i'm getting is a click out of both solenoids. Motor does nothing. Other than a bad HPU, any thoughts?
    Danny Facciola[br]1987 231 Suzuki 225[br]Edgewater, MD

  • #2
    The next step is to contact Tabman. Your sure your getting the proper vo;tage to the solinod's. Right? No low battery?

    Contact Tom here. [email protected]

    Comment


    • #3
      you have a bad hpu-you hear the relays click and nothing... you have a bad hpu.i have a good used one in my shop if you pay the shipping you may have it!!!!!

      Comment


      • #4
        Warthog -- I tested all the leads with a multi meter and voltage was fine. I even tried running it off my truck battery. Thanks for the contact info for tabman. It's an older unit that was on the boat when I bought it and I have no reciepts or warranty info on it.

        Jaws -- I'd like to take you up on the used one. Give me your info and I'll get a check or money order to you. My email address is [email protected] if you want to send the shipping adress there.
        Danny Facciola[br]1987 231 Suzuki 225[br]Edgewater, MD

        Comment


        • #5
          just sent you an email check it

          Comment

          Working...
          X